If you are working with two versions of Windows Embedded Compact on the same PC, Microsoft doesn’t make it easy for you: each version of WinCE require different Visual Studio and Platform Builder, which are not compatibile with each other. For example, WinCE5 need to be developed with VS2005 and WinCE6 with VS2008.

Here I will post some informations i found usefull.